Compatible Browsers
 Sibme works with the latest versions of:

Incompatible Browsers
 Sibme does not work with:

  • Opera
  • Other desktop browsers not listed in the Compatible Browsers section above

Sibme is a modern web application that has been enhanced by using HTML5, CSS3, and JavaScript. Different browsers still interpret these in different ways. These differences could potentially cause harmful bugs, which could lead to data being corrupted and files being overwritten.

We test and develop for the list of compatible browsers and block access to Sibme from outdated browsers and those listed as incompatible above. If Sibme is not working properly, running slowly, or crashing, please try disabling extensions in your browser to see if that fixes the problem.


 If you’re using Chrome, try using an Incognito window to use Sibme. Your extensions will not be available in this window. We currently test new developments in Sibme using the most popular extensions.

Did this answer your question?